Avisos de seguridad para Slackware seamonkey, php y mozilla-thunderbird.

El pasado primero de octubre se liberaron algunas actualizaciones de seguridad para Slackware Linux, los avisos se pueden consultar en el sitio oficial:

  • seamonkey y seamonkey-solibs actualizados a la versión 2.38 para Slackware 14.0, 14.1 y -current.
  • php actualizado a la versión 5.6.13 para Slackware 14.0, 14.1 y -current.
  • mozilla-thunderbird actualizado a la versión 38.3.0 para Slackware 14.1 y -current.

Por otro lado hubo algunas actualizaciones en el ChangeLog de Slackware -current, entre las que se incluyen:

  • pkgtools actualizado a la versión 14.2.
    Se parchearon makepkg y removepkg para soportar espacios en enlaces simbólicos. Los espacios en los nombres de archivos y directorios también funcionan, así que el soporte debe estar completo.
    Se parcheó makepkg para asegurar que el root de un paquete sea chmod 755.
    Se parcheó installpkg para incrementar la velocidad de algunas partes del script, especialmente cuando se crean enlaces simbólicos por un script de instalación. Si bash está disponible, los scripts de instalación serán traducidos para evitar abrir dos subshells por link.
    También se redujo UUOC.
    Se parcheó removepkg para incrementar la velocidad de algunas partes del script.
    Se parchó upgradepkg para incrementar la velocidad de algunas partes del script usando partes nativas de bash en vez de hacer llamadas externas. (Cambios similares podrían ser aplicados a installpkg/removepkg en el futuro, pero donde se han visto la mayoría de las mejoras es al recorrer upgradepkg contra el conjunto completo de paquetes).
  • mozilla-nss actualizado a la versión 3.20.
  • libXi actualizado a la versión 1.7.5.
  • libxcb actualizado a la versión 1.11.1.
  • mesa actualizado a la versión 11.0.2.
  • xf86-video-chips actualizado a la versión 1.2.6.
  • xf86-video-s3virge actualizado a la versión 1.10.7.
  • xf86-video-sis actualizado a la versión 0.10.8.
  • mozilla-firefox actualizado a la versión 41.0.1.

Como siempre hay que procurar actualizar lo antes posible cuando se trata de actualizaciones
de seguridad. Para ello usamos como siempre el comando slackpkg.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s